WhatsApp-gebruikers waren kwetsbaar voor spionage

14-05-2019 | door: Wouter Hoeffnagel

WhatsApp-gebruikers waren kwetsbaar voor spionage

 

Een ernstig beveiligingslek in WhatsApp maakte het mogelijk malware te installeren op smartphones van gebruikers. Met deze malware konden gebruikers vervolgens worden bespioneerd, zonder dat zij hiervan iets merkten. Het beveiligingsprobleem was aanwezig in zowel de iOS als Android app van WhatsApp en is inmiddels door Facebook gedicht.

Dit meldt de Financial Times. Het beveiligingslek werd begin mei ontdekt en zit in de belfunctie van WhatsApp. Uit een security advisory die door Facebook is gepubliceerd blijkt dat het gaat om een buffer overflow kwetsbaarheid in de WhatsApp VoIP stack. Deze kwetsbaarheid maakte het mogelijk op afstand code uit te voeren door gemanipuleerde SRTCP pakketjes naar een doelwit te sturen.

Ongemerkt malware installeren

In de praktijk betekent dit dat kwaadwillenden een WhatsApp-gebruiker konden aanvallen door deze gebruiker simpelweg op te bellen. In dit geval wordt ongemerkt code uitgevoerd op de smartphone van deze gebruiker, wat het onder meer mogelijk maakt op afstand malware op het apparaat te installeren. Ook als het gesprek niet werd beantwoord door de gebruiker, was het mogelijk via deze weg code uit te voeren.

WhatsApp bevestigt de kwetsbaarheid tegenover de Financial Times. Het bedrijf spreekt van spyware die functies van besturingssystemen voor telefoons kan overnemen. WhatApp vermoedt dat de exploit die nu beschikbaar is het werk is van een privaat bedrijf dat spyware levert aan overheden om functies van besturingssystemen van telefoons over te nemen.

NSO Group

De exploit waarmee de kwetsbaarheid kan worden uitgebuit is naar verluid afkomstig van het Israëlische bedrijf NSO Group. Dit bedrijf ontwikkelt en verkoopt spionagetechnologie. NSO Group wordt onder meer gekoppeld aan Pegasus, software die volgens Citizen Lab en Lookout eerder werd ingezet om mensenrechtenactivist Ahmed Mansoor aan te vallen in de Verenigde Arabische Emiraten. De iPhone 6 van Mansoor werd hierbij in augustus 2016 met malware geïnfecteerd nadat hij een link opende die via een sms-bericht werd toegestuurd.

De volgende versies van WhatsApp bevatten het beveiligingslek:

  • WhatsApp for Android: versies voor v2.19.134
  • WhatsApp Business for Android: versies voor v2.19.44
  • WhatsApp for iOS: versies voor v2.19.51
  • WhatsApp Business for iOS: versies voor v2.19.51 WhatsApp for Windows Phone: versies voor v2.18.348
  • WhatsApp for Tizen: versies voor v2.18.15
Terug naar nieuws overzicht

Tags